package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ssh\s\|\s(?<FIELD_NAME>\S+)`)
var str = `event 1:
31.138.204.1 | ssh | o*1N0HIQQx434x12481145x1 | ZI53713 | 2018-05-28 07:14:47,848 | SSH - piv-receive-pack '/hvq849/spcp-mdo-scoring.git' | - | 0 | 15122 | 738 | push, ssh:user:id:121237 | 1595 | 10togc8 |
event 2:
31.138.204.1 | ssh | i*1N0HIQQx434x12481145x1 | ZI53713 | 2018-05-28 07:14:47,848 | SSH - piv-receive-pack '/hvq849/spcp-mdo-scoring.git' | - | 0 | 15122 | 738 | push, ssh:user:id:121237 | 1595 | 10togc8 |
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}