use strict;
my $str = 'event 1:
31.138.204.1 | ssh | o*1N0HIQQx434x12481145x1 | ZI53713 | 2018-05-28 07:14:47,848 | SSH - piv-receive-pack \'/hvq849/spcp-mdo-scoring.git\' | - | 0 | 15122 | 738 | push, ssh:user:id:121237 | 1595 | 10togc8 |
event 2:
31.138.204.1 | ssh | i*1N0HIQQx434x12481145x1 | ZI53713 | 2018-05-28 07:14:47,848 | SSH - piv-receive-pack \'/hvq849/spcp-mdo-scoring.git\' | - | 0 | 15122 | 738 | push, ssh:user:id:121237 | 1595 | 10togc8 |
';
my $regex = qr/ssh\s\|\s(?<FIELD_NAME>\S+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}