#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[^\.\d]([\d]{8}[TRWAGMYFPDXBNJZSQVHLCKE])"
Local $sString = " GOOD --> 47099085T" & @CRLF & _
" GOOD --> D73654109H" & @CRLF & _
" NOT OK --> 8.30781719e-05" & @CRLF & _
" NOT OK --> 0113:11:19%2000:54:17.042828927Z" & @CRLF & _
"^%\*-{1,3}(?!-)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")