import re
regex = re.compile(r"[^\.\d]([\d]{8}[TRWAGMYFPDXBNJZSQVHLCKE])", flags=re.MULTILINE | re.IGNORECASE)
test_str = (" GOOD --> 47099085T\n"
" GOOD --> D73654109H\n"
" NOT OK --> 8.30781719e-05\n"
" NOT OK --> 0113:11:19%2000:54:17.042828927Z\n"
"^%\\*-{1,3}(?!-)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")