$re = '/[^\.\d]([\d]{8}[TRWAGMYFPDXBNJZSQVHLCKE])/mi';
$str = ' GOOD --> 47099085T
GOOD --> D73654109H
NOT OK --> 8.30781719e-05
NOT OK --> 0113:11:19%2000:54:17.042828927Z
^%\\*-{1,3}(?!-)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);