#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\S\s([^\r\n]*?)\s*\+[0-9]+$"
Local $sString = "๐ฆ๐ซ Afghanistan +93" & @CRLF & _
"๐ฆ๐ฝ ร
land Islands +358" & @CRLF & _
"๐ฆ๐ฑ Albania +355" & @CRLF & _
"๐ฉ๐ฟ Algeria +213" & @CRLF & _
"๐ฆ๐ธ American Samoa +1684" & @CRLF & _
"๐ฆ๐ฉ Andorra +376" & @CRLF & _
"๐ฆ๐ด Angola +244" & @CRLF & _
"๐ฆ๐ฎ Anguilla +1264"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")