import Foundation
let pattern = #"\S\s([^\r\n]*?)\s*\+[0-9]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
๐ฆ๐ซ Afghanistan +93
๐ฆ๐ฝ ร
land Islands +358
๐ฆ๐ฑ Albania +355
๐ฉ๐ฟ Algeria +213
๐ฆ๐ธ American Samoa +1684
๐ฆ๐ฉ Andorra +376
๐ฆ๐ด Angola +244
๐ฆ๐ฎ Anguilla +1264
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)