const regex = /\S\s([^\r\n]*?)\s*\+[0-9]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S\\s([^\\r\\n]*?)\\s*\\+[0-9]+$', 'gm')
const str = `๐ฆ๐ซ Afghanistan +93
๐ฆ๐ฝ ร
land Islands +358
๐ฆ๐ฑ Albania +355
๐ฉ๐ฟ Algeria +213
๐ฆ๐ธ American Samoa +1684
๐ฆ๐ฉ Andorra +376
๐ฆ๐ด Angola +244
๐ฆ๐ฎ Anguilla +1264`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}