package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^-\n]*-[^=\n]*)-.*?(\.\w+)$`)
var str = `Tab 3-3-z-o.pdf
Should be Tab 3-3.pdf
Tab 2-3-jk2.pdf
Should be: Tab 2-3.pdf
Tab 3-3-Yuwk-3-k-l-s.pdf
Should be: Tab 3-3.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}