import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^-\\n]*-[^=\\n]*)-.*?(\\.\\w+)$";
final String string = "Tab 3-3-z-o.pdf\n\n"
+ "Should be Tab 3-3.pdf\n\n"
+ "Tab 2-3-jk2.pdf\n\n"
+ "Should be: Tab 2-3.pdf\n\n"
+ "Tab 3-3-Yuwk-3-k-l-s.pdf\n\n"
+ "Should be: Tab 3-3.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}