#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^-\n]*-).*?(?i)(\.pdf)$"
Local $sString = "Tab 3-3-z-o.pdf" & @CRLF & _
"" & @CRLF & _
"Should be Tab 3-3.pdf" & @CRLF & _
"" & @CRLF & _
"Tab 2-3-jk2.pdf" & @CRLF & _
"" & @CRLF & _
"Should be: Tab 2-3.pdf" & @CRLF & _
"" & @CRLF & _
"Tab 3-3-Yuwk-3-k-l-s.pdf" & @CRLF & _
"" & @CRLF & _
"Should be: Tab 3-3.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")