use strict;
my $str = 'Tab 3-3-z-o.pdf
Should be Tab 3-3.pdf
Tab 2-3-jk2.pdf
Should be: Tab 2-3.pdf
Tab 3-3-Yuwk-3-k-l-s.pdf
Should be: Tab 3-3.pdf';
my $regex = qr/^([^-\n]*-).*?(?i)(\.pdf)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}