re = /^([^-\n]*-).*?(?i)(\.pdf)$/m
str = 'Tab 3-3-z-o.pdf
Should be Tab 3-3.pdf
Tab 2-3-jk2.pdf
Should be: Tab 2-3.pdf
Tab 3-3-Yuwk-3-k-l-s.pdf
Should be: Tab 3-3.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end