#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!")(?:\(|\b)[^"\n]+\/[^"\n]+(?:\)|\b)(?!")"
Local $sString = "some text/more text" & @CRLF & _
"(formula)/dividethis" & @CRLF & _
"divideme/(byme)" & @CRLF & _
""dont match/me"" & @CRLF & _
"" & @CRLF & _
"match/me but "not/me""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")