using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!"")(?:\(|\b)[^""\n]+\/[^""\n]+(?:\)|\b)(?!"")";
string input = @"some text/more text
(formula)/dividethis
divideme/(byme)
""dont match/me""
match/me but ""not/me""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}