$re = '/(?<!")(?:\(|\b)[^"\n]+\/[^"\n]+(?:\)|\b)(?!")/';
$str = 'some text/more text
(formula)/dividethis
divideme/(byme)
"dont match/me"
match/me but "not/me"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);