#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)^ .* [a-z\d] .* [а-я] .* $ | ^ .* [а-я] .* [a-z\d] .* $ "
Local $sString = "aaa" & @CRLF & _
"bbb" & @CRLF & _
"a1c" & @CRLF & _
"zzяяzzяя" & @CRLF & _
"п1п" & @CRLF & _
"wwя" & @CRLF & _
"я12" & @CRLF & _
"яяя" & @CRLF & _
"1я" & @CRLF & _
"1яa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")