using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ .* [a-z\d] .* [а-я] .* $ | ^ .* [а-я] .* [a-z\d] .* $ ";
string input = @"aaa
bbb
a1c
zzяяzzяя
п1п
wwя
я12
яяя
1я
1яa";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}