$re = '/^ .* [a-z\d] .* [а-я] .* $ | ^ .* [а-я] .* [a-z\d] .* $ /xm';
$str = 'aaa
bbb
a1c
zzяяzzяя
п1п
wwя
я12
яяя
1я
1яa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);