const regex = new RegExp('^/(?<page>(?:post_beta|breaking_post_beta|post_beta_static)(?:/.*)?)$', 'gm')
const str = `Should match:
/post_beta
/breaking_post_beta
/post_beta_static
Should not match:
/post
/breaking_post
/post.json
/breaking_post.json
/post_beta.json
/breaking_post_beta.json`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}