// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^/(?<page>(?:post_beta|breaking_post_beta|post_beta_static)(?:/.*)?)$").unwrap();
let string = "Should match:
/post_beta
/breaking_post_beta
/post_beta_static
Should not match:
/post
/breaking_post
/post.json
/breaking_post.json
/post_beta.json
/breaking_post_beta.json";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}