const regex = /^(?!.*[ ]{2})(?!.* ,).*\b(?:\p{L}+|\d{3})\.\w{3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*[ ]{2})(?!.* ,).*\\b(?:\\p{L}+|\\d{3})\\.\\w{3}$', 'gm')
const str = `File name without 3 digit end.jpg
File name with 3 digit 123.gif
File name with 3, digit 123.gif
Single 123.jpg
Single.png
File name with ,3 digit 123.gif
Single 123.jpg
Single 1.jpg
Single 123b.gif
More words 123b.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}