$re = '/^(?!.*[ ]{2})(?!.* ,).*\b(?:\p{L}+|\d{3})\.\w{3}$/m';
$str = 'File name without 3 digit end.jpg
File name with 3 digit 123.gif
File name with 3, digit 123.gif
Single 123.jpg
Single.png
File name with ,3 digit 123.gif
Single 123.jpg
Single 1.jpg
Single 123b.gif
More words 123b.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);