import re
regex = re.compile(r"^(?!.*[ ]{2})(?!.* ,).*\b(?:\p{L}+|\d{3})\.\w{3}$", flags=re.MULTILINE)
test_str = ("File name without 3 digit end.jpg\n"
"File name with 3 digit 123.gif\n"
"File name with 3, digit 123.gif\n"
"Single 123.jpg\n"
"Single.png\n\n\n"
"File name with ,3 digit 123.gif\n"
"Single 123.jpg\n"
"Single 1.jpg\n"
"Single 123b.gif\n"
"More words 123b.png")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")