#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"@\w+"
Local $sString = "INSERT INTO Recibos (idRecibo, DataRecibo, NomeCliente, Valor, CPFCliente, EnderecoCliente, NumeroCliente, BairroCliente, Importancia, Referente, Cidade, UF, Emitente, EnderecoEmitente, NumeroEmitente, BairroEmitente, CPFEmitente, RG) VALUES (" +" & @CRLF & _
" "@idRecibo," +" & @CRLF & _
" "@dataRecibo," +" & @CRLF & _
" "@nomeCliente," +" & @CRLF & _
" "@valor," +" & @CRLF & _
" "@cpfCliente," +" & @CRLF & _
" "@endCliente," +" & @CRLF & _
" "@numCliente," +" & @CRLF & _
" "@baiCliente," +" & @CRLF & _
" "@importancia," +" & @CRLF & _
" "@referente, +" +" & @CRLF & _
" "@cidade," +" & @CRLF & _
" "@uf," +" & @CRLF & _
" "@emitente," +" & @CRLF & _
" "@endEmitente," +" & @CRLF & _
" "@numEmitente," +" & @CRLF & _
" "@baiEmitente," +" & @CRLF & _
" "@cpfEmitente," +" & @CRLF & _
" "@rg)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")