package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"@\w+`)
var str = `INSERT INTO Recibos (idRecibo, DataRecibo, NomeCliente, Valor, CPFCliente, EnderecoCliente, NumeroCliente, BairroCliente, Importancia, Referente, Cidade, UF, Emitente, EnderecoEmitente, NumeroEmitente, BairroEmitente, CPFEmitente, RG) VALUES (" +
"@idRecibo," +
"@dataRecibo," +
"@nomeCliente," +
"@valor," +
"@cpfCliente," +
"@endCliente," +
"@numCliente," +
"@baiCliente," +
"@importancia," +
"@referente, +" +
"@cidade," +
"@uf," +
"@emitente," +
"@endEmitente," +
"@numEmitente," +
"@baiEmitente," +
"@cpfEmitente," +
"@rg)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}