$re = '/"@\w+/m';
$str = 'INSERT INTO Recibos (idRecibo, DataRecibo, NomeCliente, Valor, CPFCliente, EnderecoCliente, NumeroCliente, BairroCliente, Importancia, Referente, Cidade, UF, Emitente, EnderecoEmitente, NumeroEmitente, BairroEmitente, CPFEmitente, RG) VALUES (" +
"@idRecibo," +
"@dataRecibo," +
"@nomeCliente," +
"@valor," +
"@cpfCliente," +
"@endCliente," +
"@numCliente," +
"@baiCliente," +
"@importancia," +
"@referente, +" +
"@cidade," +
"@uf," +
"@emitente," +
"@endEmitente," +
"@numEmitente," +
"@baiEmitente," +
"@cpfEmitente," +
"@rg)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);