using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:M|N.{7}|C.{6})(.{7})\S*([A-Z][a-z]+)\s*(\S+)";
string input = @"M18L9P3H013QLVMSKrystoper Pines B0R7US
NJ669V9S10A3JCKBrian Oconnor B0JG
CFSJ1TS196M0L8William Steele B0BJV
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}