const regex = /^(?:M|N.{7}|C.{6})(.{7})\S*([A-Z][a-z]+)\s*(\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:M|N.{7}|C.{6})(.{7})\\S*([A-Z][a-z]+)\\s*(\\S+)', 'gm')
const str = `M18L9P3H013QLVMSKrystoper Pines B0R7US
NJ669V9S10A3JCKBrian Oconnor B0JG
CFSJ1TS196M0L8William Steele B0BJV
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}