$re = '/^(?:M|N.{7}|C.{6})(.{7})\S*([A-Z][a-z]+)\s*(\S+)/m';
$str = 'M18L9P3H013QLVMSKrystoper Pines B0R7US
NJ669V9S10A3JCKBrian Oconnor B0JG
CFSJ1TS196M0L8William Steele B0BJV
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);