using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^group |\G(?!^))(\S+)(?:\s+|$)";
string input = @"group g1 l1 l2 l3 g2 g3.l1
group g1 g2.l1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}