const regex = /(?:^group |\G(?!^))(\S+)(?:\s+|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^group |\\G(?!^))(\\S+)(?:\\s+|$)', 'gm')
const str = `group g1 l1 l2 l3 g2 g3.l1
group g1 g2.l1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}