const regex = /^otpauth:\/\/totp\/([A-Za-z0-9%]+)(\?issuer=[A-Za-z0-9%]+&secret=[A-Z2-7]+=*&algorithm=(SHA1|SHA256|SHA512)&digits=\d{6}&period=\d{2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^otpauth:\\\/\\\/totp\\\/([A-Za-z0-9%]+)(\\?issuer=[A-Za-z0-9%]+&secret=[A-Z2-7]+=*&algorithm=(SHA1|SHA256|SHA512)&digits=\\d{6}&period=\\d{2})?$', 'gm')
const str = `otpauth://totp/TestLabel%3A?issuer=Test%20Issuer&secret=I65VU7K5ZQL7WB4E&algorithm=SHA1&digits=6&period=30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}