// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^otpauth:\/\/totp\/([A-Za-z0-9%]+)(\?issuer=[A-Za-z0-9%]+&secret=[A-Z2-7]+=*&algorithm=(SHA1|SHA256|SHA512)&digits=\d{6}&period=\d{2})?$").unwrap();
let string = "otpauth://totp/TestLabel%3A?issuer=Test%20Issuer&secret=I65VU7K5ZQL7WB4E&algorithm=SHA1&digits=6&period=30";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}