# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^www\d*\.(?=.*\.)//gm;t' <<< "www.by
www.ru
www.example.org
www.sub.example.org"