$re = '/^www\d*\.(?=.*\.)/m';
$str = 'www.by
www.ru
www.example.org
www.sub.example.org';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;