#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^www\d*\.(?=.*\.)"
Local $sString = "www.by" & @CRLF & _
"www.ru" & @CRLF & _
"www.example.org" & @CRLF & _
"www.sub.example.org"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)