using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w].*_\d+\.m[p4].$";
string input = @"gdgdf ddfdf dgdgd.mp4
gdgdg dgdgdg gdfdfd_2.mp4
mdhdgd gdgdgd hdydd_3.mp3
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}