re = /[\w].*_\d+\.m[p4].$/m
str = 'gdgdf ddfdf dgdgd.mp4
gdgdg dgdgdg gdfdfd_2.mp4
mdhdgd gdgdgd hdydd_3.mp3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end