import re
regex = re.compile(r"[\w].*_\d+\.m[p4].$", flags=re.MULTILINE)
test_str = ("gdgdf ddfdf dgdgd.mp4\n"
"gdgdg dgdgdg gdfdfd_2.mp4\n"
"mdhdgd gdgdgd hdydd_3.mp3\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")