import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "RafflesBotto(?:.|\\n)*span\\sclass=\"pl-2.?>x\\s*([0-9]+)<";
final String string = "<div class=\"RafflesBottomBackgroundWrapper d-flex justify-content-between\"><div class=\"align-self-center\"><img class=\"ml-4 my-3\" src=\"https://assets.tophatter.com/assets/raffle/ticket_enabled-2c999ae451057b4f75762c500dc20ce0183176ab98068a5864a7c16d68bae720.png\" width=\"24\" height=\"16\"><span class=\"pl-2\">x 100</span></div><button type=\"button\" class=\"btn btn-lg btn-primary mr-4 my-2 w-30\"><span><span class=\"fa fa-star\"></span><span class=\"ml-1\">20</span></span></button></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}