#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\G(?!\A)|{)[^{}]*?\K\([^()]*\)(?=[^{}]*})"
Local $sString = "{foo (i,j) bar} should match on (i,j)" & @CRLF & _
"{(i,j) foo (k,l) bar (m,n,o)} should match on (i,j), (k,l), and (m,n,o)." & @CRLF & _
"foo (i,j) bar should not match on anything because the string is not between swirly brackets." & @CRLF & _
"{foo (i,j) bar} (k,l) should match on (i,j) but not (k,l) because the latter is outside of the swirly brackets."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")