using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|{)[^{}]*?\K\([^()]*\)(?=[^{}]*})";
string input = @"{foo (i,j) bar} should match on (i,j)
{(i,j) foo (k,l) bar (m,n,o)} should match on (i,j), (k,l), and (m,n,o).
foo (i,j) bar should not match on anything because the string is not between swirly brackets.
{foo (i,j) bar} (k,l) should match on (i,j) but not (k,l) because the latter is outside of the swirly brackets.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}