import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Begin:.*(?:\\R(?!ModelFinish).*)*(?=\\RSaving)";
final String string = "Begin: model 17\n"
+ "Epoch 15800, loss 4051304.017, val_PMAE 6.9\n"
+ "Saving at epoch 15828 with loss: 3974847.290\n"
+ "Saving at epoch 15889 with loss: 3968749.471\n"
+ "ModelFinish: Stop training\n"
+ "Begin: model 18\n"
+ "Saving at epoch 15889 with loss: 3968749.223\n"
+ "Saving at epoch 15889 with loss: 3968749.200\n"
+ "Epoch 15800, loss 4051304.017\n"
+ "ModelFinish: Stop training\n"
+ "Begin: model 19\n"
+ "Saving at epoch 15889 with loss: 3968749.223\n"
+ "Saving at epoch 15889 with loss: 3968749.200\n"
+ "Saving at epoch 15889 with loss: 3968749.200\n"
+ "Saving at epoch 15889 with loss: 3968749.200\n"
+ "Saving at epoch 15889 with loss: 3968749.200\n"
+ "Saving at epoch 15889 with loss: 3968749.200\n"
+ "Saving at epoch 15889 with loss: 3968749.200\n"
+ "Epoch 15800, loss 4051304.017\n"
+ "ModelFinish: Stop training";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}