re = /^Begin:.*(?:\R(?!ModelFinish).*)*(?=\RSaving)/m
str = 'Begin: model 17
Epoch 15800, loss 4051304.017, val_PMAE 6.9
Saving at epoch 15828 with loss: 3974847.290
Saving at epoch 15889 with loss: 3968749.471
ModelFinish: Stop training
Begin: model 18
Saving at epoch 15889 with loss: 3968749.223
Saving at epoch 15889 with loss: 3968749.200
Epoch 15800, loss 4051304.017
ModelFinish: Stop training
Begin: model 19
Saving at epoch 15889 with loss: 3968749.223
Saving at epoch 15889 with loss: 3968749.200
Saving at epoch 15889 with loss: 3968749.200
Saving at epoch 15889 with loss: 3968749.200
Saving at epoch 15889 with loss: 3968749.200
Saving at epoch 15889 with loss: 3968749.200
Saving at epoch 15889 with loss: 3968749.200
Epoch 15800, loss 4051304.017
ModelFinish: Stop training'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end