#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=t\(').+?(?='\))|(?<=t\(").+?(?="\))|(?<=t\(`).+?(?=`\))|(?<=t\(").+?(?=", {)|(?<=t\(').+?(?=', {)|(?<=t\(`).+?(?=`, {)"
Local $sString = "{" & @CRLF & _
" id: 11," & @CRLF & _
" image: 'best-broker-latin-america.jpg'," & @CRLF & _
" title: this.$t("TEXT")," & @CRLF & _
" description: \`<p><span>${ this.$t("TEXT") }</span> <span>${ this.$t("TEXT", { company: 'LiteFinance' }) }</span></p>\`" & @CRLF & _
" }," & @CRLF & _
"" & @CRLF & _
"$t('TEXT')" & @CRLF & _
"$t("TEXT")" & @CRLF & _
"$t("TEXT", { link: '#', company: 'LiteFinance' })" & @CRLF & _
"$t('TEXT', { link: '#', company: 'LiteFinance' })" & @CRLF & _
"$t('TEXT "TEXT" TEXT')" & @CRLF & _
"$t(`TEXT`)" & @CRLF & _
"$t(`TEXT`, { link: '#', company: 'LiteFinance' })" & @CRLF & _
"" & @CRLF & _
"С ПЕРЕНОСАМИ" & @CRLF & _
"${ this.$t('TEXT', { company: this.$global.company }) } " & @CRLF & _
"${ this.$t('TEXT', { num: this.bonus }) }" & @CRLF & _
"" & @CRLF & _
"ОДНОЙ СТРОКОЙ" & @CRLF & _
"${ this.$t("TEXT", { company: this.$global.company }) } ${ this.$t("TEXT", { num: this.bonus }) }" & @CRLF & _
"`${ this.$t('TEXT', { company: this.$global.company }) }${ this.$t('TEXT', { num: this.bonus }) }`" & @CRLF & _
"asyncData({ store, i18n }) {" & @CRLF & _
" // breadcrumbs" & @CRLF & _
"" & @CRLF & _
" store.commit('breadcrumbs/setCrumbs', [" & @CRLF & _
" {" & @CRLF & _
" name: i18n.t('TEXT')," & @CRLF & _
" url: '/'" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" name: i18n.t('TEXT')," & @CRLF & _
" url: '/about'" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" name: i18n.t('TEXT')" & @CRLF & _
" }" & @CRLF & _
" ])" & @CRLF & _
" }," & @CRLF & _
"case 'cryptocurrencies':" & @CRLF & _
" return this.$t('TEXT', { company: this.$global.company, num: this.$global.companyAge });" & @CRLF & _
" case 'currencies':" & @CRLF & _
" return this.$t('TEXT TEXT TEXT', {" & @CRLF & _
" company: this.$global.company," & @CRLF & _
" num: this.$global.companyAge" & @CRLF & _
" }" & @CRLF & _
" );" & @CRLF & _
"case 'cryptocurrencies':"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")