const regex = /(?<=t\(').+?(?='\))|(?<=t\(").+?(?="\))|(?<=t\(`).+?(?=`\))|(?<=t\(").+?(?=", {)|(?<=t\(').+?(?=', {)|(?<=t\(`).+?(?=`, {)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=t\\(\').+?(?=\'\\))|(?<=t\\(").+?(?="\\))|(?<=t\\(`).+?(?=`\\))|(?<=t\\(").+?(?=", {)|(?<=t\\(\').+?(?=\', {)|(?<=t\\(`).+?(?=`, {)', 'gm')
const str = `{
id: 11,
image: 'best-broker-latin-america.jpg',
title: this.\$t("TEXT"),
description: \\\`<p><span>\${ this.\$t("TEXT") }</span> <span>\${ this.\$t("TEXT", { company: 'LiteFinance' }) }</span></p>\\\`
},
\$t('TEXT')
\$t("TEXT")
\$t("TEXT", { link: '#', company: 'LiteFinance' })
\$t('TEXT', { link: '#', company: 'LiteFinance' })
\$t('TEXT "TEXT" TEXT')
\$t(\`TEXT\`)
\$t(\`TEXT\`, { link: '#', company: 'LiteFinance' })
С ПЕРЕНОСАМИ
\${ this.\$t('TEXT', { company: this.\$global.company }) }
\${ this.\$t('TEXT', { num: this.bonus }) }
ОДНОЙ СТРОКОЙ
\${ this.\$t("TEXT", { company: this.\$global.company }) } \${ this.\$t("TEXT", { num: this.bonus }) }
\`\${ this.\$t('TEXT', { company: this.\$global.company }) }\${ this.\$t('TEXT', { num: this.bonus }) }\`
asyncData({ store, i18n }) {
// breadcrumbs
store.commit('breadcrumbs/setCrumbs', [
{
name: i18n.t('TEXT'),
url: '/'
},
{
name: i18n.t('TEXT'),
url: '/about'
},
{
name: i18n.t('TEXT')
}
])
},
case 'cryptocurrencies':
return this.\$t('TEXT', { company: this.\$global.company, num: this.\$global.companyAge });
case 'currencies':
return this.\$t('TEXT TEXT TEXT', {
company: this.\$global.company,
num: this.\$global.companyAge
}
);
case 'cryptocurrencies':`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}