use strict;
my $str = '{
id: 11,
image: \'best-broker-latin-america.jpg\',
title: this.$t("TEXT"),
description: \\`<p><span>${ this.$t("TEXT") }</span> <span>${ this.$t("TEXT", { company: \'LiteFinance\' }) }</span></p>\\`
},
$t(\'TEXT\')
$t("TEXT")
$t("TEXT", { link: \'#\', company: \'LiteFinance\' })
$t(\'TEXT\', { link: \'#\', company: \'LiteFinance\' })
$t(\'TEXT "TEXT" TEXT\')
$t(`TEXT`)
$t(`TEXT`, { link: \'#\', company: \'LiteFinance\' })
С ПЕРЕНОСАМИ
${ this.$t(\'TEXT\', { company: this.$global.company }) }
${ this.$t(\'TEXT\', { num: this.bonus }) }
ОДНОЙ СТРОКОЙ
${ this.$t("TEXT", { company: this.$global.company }) } ${ this.$t("TEXT", { num: this.bonus }) }
`${ this.$t(\'TEXT\', { company: this.$global.company }) }${ this.$t(\'TEXT\', { num: this.bonus }) }`
asyncData({ store, i18n }) {
// breadcrumbs
store.commit(\'breadcrumbs/setCrumbs\', [
{
name: i18n.t(\'TEXT\'),
url: \'/\'
},
{
name: i18n.t(\'TEXT\'),
url: \'/about\'
},
{
name: i18n.t(\'TEXT\')
}
])
},
case \'cryptocurrencies\':
return this.$t(\'TEXT\', { company: this.$global.company, num: this.$global.companyAge });
case \'currencies\':
return this.$t(\'TEXT TEXT TEXT\', {
company: this.$global.company,
num: this.$global.companyAge
}
);
case \'cryptocurrencies\':';
my $regex = qr/(?<=t\(').+?(?='\))|(?<=t\(").+?(?="\))|(?<=t\(`).+?(?=`\))|(?<=t\(").+?(?=", {)|(?<=t\(').+?(?=', {)|(?<=t\(`).+?(?=`, {)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}