using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(LastName)>(.*?)<\/\1>(?![\s\S]*?<\1>\2<\/\1>)";
string input = @" <LastName>Adams</LastName>
<LastName>Adams</LastName>
<LastName>Yellow</LastName>
<LastName>Adams</LastName>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}