$re = '/<(LastName)>(.*?)<\/\1>(?![\s\S]*?<\1>\2<\/\1>)/m';
$str = ' <LastName>Adams</LastName>
<LastName>Adams</LastName>
<LastName>Yellow</LastName>
<LastName>Adams</LastName>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);